W3 Total Cache: cập nhật lỗi bảo mật

W3 total cache

W3 Total Cache là một plugin rất hữu dụng cho các websites sử dụng mã nguồn WordPress. Nó xây dựng các bộ nhớ đệm, lưu trữ các kết quả đã được tìm kiếm trong cơ sở dữ liệu, các files dữ liệu tĩnh… cũng như kết hợp cấu hình các bộ đêm Varnish hay sử dụng CDN. Tất cả đều làm mục đích giảm các requests liên tục vào database, tăng tốc độ truy xuất website.

Tuy nhiên, bộ plugin này vừa gặp một lỗi khá nguy hiểm: có thể thực thi các câu lệnh server, chỉ cần qua comment bài viết. Ví dụ, bạn có thể kiểm tra comment với nội dung

<!–mfunc echo PHP_VERSION; –><!–/mfunc–>

Nếu comment hiển thị lại cho bạn thông số phiên bản PHP trên server, phiên bản W3 Total Cache bạn dùng đang gặp vấn đề. Hãy tưởng tượng nếu hacker không chỉ muốn hiển thị thông số phiên bản PHP, mà muốn thực thi các câu lệnh khác. Thậm chí những công cụ hacks được mã hoá base64, rất hay gặp với các script-kidders, đều được bộ plugin này xử lý câu lệnh bình thường.

Một plugin khác tương tự là WP Super Cache cũng gặp lỗi bảo mật tương tự. 

VietNAP khuyến nghị tất cả các sites WordPress, có sử dụng các bộ plugins trên, cần nâng cấp lên phiên bản mới nhất để khắc phục.

  • Với W3 Total Cache, phiên bản mới nhất là 0.9.2.9
  • Với WP Super Cache, phiên bản mới nhất là 1.3.1

Tất cả các phiên bản cũ hơn đều gặp lỗi bảo mật trên. Với các khách hàng sử dụng dịch vụ Managed WordPress Hosting, VietNAP đã thực hiện việc cập nhật các phiên bản mới nhất cách đây vài ngày, khi bản vá được đưa ra. Với các khách hàng khác, chúng tôi khuyến nghị nâng cấp ngay lập tức, tránh việc websites của bạn bị khai thác.

Viết một bình luận