Lựa chọn phiên bản PHP khác nhau

Tại các máy chủ CloudLinux Hosting của VietNAP, chúng tôi sẽ hỗ trợ các phiên bản PHP khác nhau. Điều này hỗ trợ khách hàng có thể lựa chọn cho phù hợp với nhu cầu sử dụng của mình. Nếu bạn không chắc chắn cần sử dụng phiên bản nào, bạn có thể gửi mail cho VietNAP, chúng tôi sẽ kiểm tra và trả lời chi tiết.

[div class=”greenbox”]

  • Với các máy chủ WordPress Hosting, chúng tôi luôn chạy một phiên bản PHP mới nhất. VietNAP sẽ kiểm tra, đưa ra khuyến nghị với khách hàng về việc sử dụng plugins và themes ra sao để phù hợp với phiên bản này.
  • Với các máy chủ ảo VPS, theo mặc định, chúng tôi cũng chỉ cài đặt một phiên bản PHP mới nhất. Nếu bạn muốn sử dụng nhiều phiên bản PHP khác nhau, vui lòng liên hệ với hỗ trợ kỹ thuật, chúng tôi sẽ cài đặt cho bạn.

[end-div]

Tại sao chỉ có một phiên bản PHP 5.x?

Hiện tại, phiên bản cũ nhất của PHP được VietNAP hỗ trợ là 5.6. Mặc dù vẫn có thể cài đặt các phiên bản cũ hơn, nhưng các phiên bản cũ khi đã không còn được phát triển (End of life – EOL), nếu có lỗ hổng bảo mật mới được phát hiện, nó cũng sẽ không được vá. Khi đó, hệ thống sẽ rơi vào tình trạng kém bảo mật, và website của khách hàng có thể bị lợi dụng.

Bạn cũng nên lưu ý kiểm tra script đang sử dụng. Nếu script quá cũ, không được nâng cấp, không phù hợp với các phiên bản PHP mới nhất, script đó có thể gặp lỗi bảo mật. Trong trường hợp đó, nên kiểm tra nâng cấp script hoặc tìm các script mới phù hợp hơn.

Cách chọn các phiên bản PHP khác nhau?

Khách hàng có thể dễ dàng chọn phiên bản PHP phù hợp qua các bước sau:

  1. Đăng nhập DirectAdmin.
  2. Trong phần Advanced Features, bấm link Select PHP version.
  3. Chọn phiên bản PHP phù hợp và bấm nút Set as current.

phiên bản PHP khác nhau